Absa EFTs offline
Incident Report for PayFast
Resolved
All Absa EFT functionality returned to normal.
Posted Sep 15, 2019 - 16:58 SAST
Identified
All Absa EFTs are currently offline. The issue has been identified and our engineers are tending to it. EFTs via other banks, as well as other payment methods are still available.
Posted Sep 15, 2019 - 13:43 SAST
This incident affected: Payments :: Instant EFT (ABSA).