Standard Bank Internet Banking Intermittent Errors
Incident Report for PayFast
Resolved
This incident appears to be resolved.
Posted Aug 08, 2019 - 18:49 SAST
Monitoring
Standard Bank internet banking is experiencing intermittent errors which are impacting buyer's ability to make payments as well as the success rates for our automated EFT solution. As the issue sits with Standard Bank we are only able to monitor the situation and will do so and update this incident once the matter appears resolved.
Posted Aug 08, 2019 - 14:36 SAST
This incident affected: Payments :: Instant EFT (Standard Bank).