Intermittant Support Service
Incident Report for PayFast
Resolved
This incident has been resolved.
Posted 9 months ago. Nov 30, 2018 - 12:36 SAST
Identified
Loadshedding is affecting our support centre. Please note that emails and phone calls may be affected.
Posted 9 months ago. Nov 30, 2018 - 10:54 SAST
This incident affected: Helpdesk.