Some card transactions are failing due to processing failures at Absa.
Incident Report for Payfast
Resolved
This incident has been resolved.
Posted Aug 21, 2019 - 15:52 SAST
Monitoring
Some card transactions are failing due to issues at Absa. This will affect certain buyers' ability to pay via credit card and a number of merchants ability to receive payment by card.
Posted Aug 21, 2019 - 15:43 SAST
This incident affected: Credit & Cheque cards (Credit and Cheque Card payments).