Masterpass Payment Issues
Incident Report for Payfast
Resolved
Upstream has confirmed resolution of Debit Card payment issues.
Posted Feb 10, 2020 - 14:58 SAST
Update
We are continuing to investigate this issue.
Posted Feb 10, 2020 - 14:39 SAST
Investigating
We have detected issues on the MasterPass banking interface which is resulting in very low success rates on Debit Card transactions.
Initial investigations are pointing at upstream issues resulting in bad gateway errors.
PayFast has engaged with Masterpass and is looking to obtain resolution as soon as possible. We advise all clients to utilize alternate payment methods such as EFT or Credit Cards in the interim as these are all unaffected.
Posted Feb 10, 2020 - 14:16 SAST
This incident affected: Other payment methods (Masterpass, Debit Cards).