Absa Card Transactions down
Incident Report for Payfast
Resolved
This incident has been resolved.
Posted Aug 20, 2019 - 12:49 SAST
Monitoring
Absa card systems are currently down. All other payment methods are still operational.
Posted Aug 20, 2019 - 12:35 SAST
This incident affected: Credit & Cheque cards (Credit and Cheque Card payments).