Nedbank issued cards are failing 3Dsecure
Incident Report for Payfast
Resolved
A fix was deployed for this by BankservAfrica at 17:00 today and success rates have steadily improved since then such that everything is now back to normal.
Posted Mar 17, 2020 - 18:51 SAST
Identified
Nedbank issued credit and cheque cards are failing the 3dsecure process. The issue has been identified at an upstream partner and we are awaiting details on when a fix can be applied. Other cards and payment methods are not affected and may be used in the interim.
Posted Mar 17, 2020 - 12:41 SAST
This incident affected: Credit & Cheque cards (Credit and Cheque Card payments).