Capitec Internet Banking down
Incident Report for Payfast
Resolved
This incident has been resolved.
Posted Aug 04, 2022 - 13:21 SAST
Monitoring
Capitec Internet banking is down or highly unresponsive (https://downdetector.co.za/status/capitec/). This will affect any clients wishing to pay via Instant EFT from Capitec Bank. All other payment methods are unaffected. We will monitor and advise once regular operation resumes.
Posted Aug 04, 2022 - 10:49 SAST
This incident affected: Instant EFT (Capitec).