FNB Internet banking - Reduced functionality
Incident Report for PayFast
Resolved
FNB internet banking functionality has returned to normal.
Posted about 1 month ago. May 07, 2019 - 15:32 SAST
Monitoring
FNB Internet banking is experiencing an "outage" which is resulting in "reduced functionality" on their online banking platform. This may affect buyers' ability to make payment via EFT from FNB.
Posted about 1 month ago. May 07, 2019 - 12:22 SAST
This incident affected: Payments :: Instant EFT.