Processing interruption
Incident Report for Payfast
Resolved
The issue has been resolved. Our apologies for the unexpected outage. We're are investigating as to the cause of the interruption such that the necessary corrective action can be taken.
Posted Dec 09, 2019 - 22:07 SAST
Investigating
We are experiencing a processing outage and are investigating as to the root cause.
Posted Dec 09, 2019 - 21:12 SAST
This incident affected: Credit & Cheque cards (Credit and Cheque Card payments), Instant EFT (Capitec, FNB, Standard Bank, Absa, Nedbank, Investec), and Other payment methods (Masterpass, Debit Cards, Mobicred, SCode).