Instant EFT payments from Standard Bank unavailable
Incident Report for Payfast
Resolved
The issue affecting Standard Bank has been resolved and Instant EFT payments from Standard Bank are available again with success rates returning to normal.
Posted Aug 13, 2020 - 11:23 SAST
Investigating
Instant EFT payments from Standard Bank are currently unavailable. We are investigating the issue.
Posted Aug 13, 2020 - 09:31 SAST
This incident affected: Instant EFT (Standard Bank).