Nedbank Internet Banking down
Incident Report for PayFast
Resolved
This incident has been resolved.
Posted Oct 15, 2021 - 12:15 SAST
Monitoring
Nedbank Internet banking is down or highly unresponsive (https://downdetector.co.za/status/nedbank/). This will affect any clients wishing to pay via Instant EFT from Nedbank. All other payment methods are unaffected. We will monitor and advise once regular operation resumes.
Posted Oct 15, 2021 - 09:08 SAST
This incident affected: Payments :: Instant EFT (Nedbank).