Helpdesk provider outage
Incident Report for Payfast
Resolved
Our helpdesk provider has resolved the infrastructure issue and customer services is back to full operation. A reminder that the team is still dealing with a large backlog due to the unprecedented increase in digital payment volume at this time.
Posted Jun 01, 2020 - 16:15 SAST
Monitoring
Our cloud based helpdesk provider is experiencing an infrastructure issue which is heavily impacting our customer service team. The issue has been escalated and is being attended to by the provider. We await their resolution of the issue.
Posted Jun 01, 2020 - 10:51 SAST
This incident affected: General (HelpDesk).