Capitec Internet Banking down
Incident Report for Payfast
Resolved
Capitec internet banking is operational again and success rates are returning to normal.
Posted Nov 13, 2019 - 16:41 SAST
Monitoring
Capitec Internet banking is intermittently down (https://downdetector.co.za/status/capitec/). This will affect any clients wishing to pay via Instant EFT from Capitec Bank. We will monitor and advise once regular operation resumes.
Posted Nov 13, 2019 - 15:40 SAST
This incident affected: Instant EFT (Capitec).