Credit Card Transactions Down
Incident Report for Payfast
Resolved
This incident has been resolved.
Posted Aug 02, 2018 - 15:41 SAST
Monitoring
Processing is down and all parties are attending to the problem.
Posted Aug 02, 2018 - 15:31 SAST
This incident affected: Credit & Cheque cards (Credit and Cheque Card payments).