Standard Bank payments down
Incident Report for PayFast
Resolved
A fix has been implemented to correct the issue with Standard Banks and success rates are returning to normal.
Posted Mar 24, 2020 - 10:23 SAST
Investigating
There is an issue with Standard Bank EFT payments via Instant EFT. We are investigating.
Posted Mar 24, 2020 - 08:36 SAST
This incident affected: Payments :: Instant EFT (Standard Bank).