3D Secure issues affecting Mastercard cardholders
Incident Report for PayFast
Resolved
This issue has been resolved and all card transaction processing has returned to normal.
Posted 5 months ago. Apr 05, 2019 - 15:05 SAST
Monitoring
Bankservafrica is experiencing issues on 3D Secure acquiring affecting Mastercard transactions. They are unable to connect to Mastercard's directory server. Bankservafrica are working together with Mastercard to resolve the issue. During this time, Mastercard cardholders may have trouble successfully completing transactions. Alternative payment methods including Instant EFT are available and fully operational.
Posted 5 months ago. Apr 05, 2019 - 08:47 SAST
This incident affected: Payments :: Credit & Cheque Cards.