Bankserv Nedbank 3dsecure failures
Incident Report for PayFast
Resolved
Bankserv has resolved the issue and all card transactions are operating as per normal.
Posted 6 months ago. Mar 05, 2019 - 12:10 SAST
Monitoring
We are currently experiencing issues with 3dsecure lookups for all Nedbank merchants. Bankserv has been notified and we are awaiting feedback. This outage will affect card payments and all other payment methods are available.
Posted 6 months ago. Mar 05, 2019 - 10:08 SAST
This incident affected: Payments :: Credit & Cheque Cards.