Capitec Internet Banking down
Incident Report for PayFast
Resolved
Capitec internet banking is operational again and success rates have returned to normal.
Posted Mar 13, 2020 - 12:03 SAST
Monitoring
Capitec Internet banking is down or highly unresponsive (https://downdetector.co.za/status/capitec/). This will affect any clients wishing to pay via Instant EFT from Capitec Bank. All other payment methods are unaffected. We will monitor and advise once regular operation resumes.
Posted Mar 13, 2020 - 09:13 SAST
This incident affected: Payments :: Instant EFT (Capitec).