FNB Internet Banking down
Incident Report for PayFast
Resolved
FNB Internet Banking has been restored.
Posted 4 months ago. Jun 18, 2019 - 13:40 SAST
Monitoring
FNB Internet banking is currently down and has been since approximately 11:00 this morning. This will affect our ability to process Instant EFT payments from FNB together with any FNB clients' inability to actually pay. We will continue to monitor the situation and update this incident once FNB has resolved the issue.
Posted 4 months ago. Jun 18, 2019 - 12:48 SAST
This incident affected: Payments :: Instant EFT (FNB).