Instant EFT payments from Investec unavailable
Incident Report for PayFast
Resolved
Payments from Investec through Instant EFT are operational again.
Posted Jun 05, 2020 - 19:25 SAST
Identified
Instant EFT payments from Investec are currently unavailable. The issue has been identified and is being worked on.
Posted Jun 05, 2020 - 15:37 SAST
This incident affected: Payments :: Instant EFT (Investec).