Some card transactions are failing due to processing failures at Absa.
Incident Report for PayFast
Resolved
This incident has been resolved.
Posted Aug 20, 2019 - 14:45 SAST
Monitoring
Some card transactions are failing due to issues at Absa. This will affect certain buyers' ability to pay via credit card and a number of merchants ability to receive payment by card.
Posted Aug 20, 2019 - 13:19 SAST
This incident affected: Payments :: Credit & Cheque Cards.