FNB Internet Banking down
Incident Report for PayFast
Resolved
FNB Internet banking is back up and running and success rates have returned to normal.
Posted Apr 03, 2020 - 17:05 SAST
Monitoring
FNB Internet banking is down or highly unresponsive (https://downdetector.co.za/status/fnb/). This will affect any clients wishing to pay via Instant EFT from FNB. All other payment methods are unaffected. We will monitor and advise once regular operation resumes.
Posted Apr 03, 2020 - 13:55 SAST
This incident affected: Payments :: Instant EFT (FNB).