Higher than normal failure rate
Incident Report for Payfast
Resolved
This issue has been resolved.
Posted Nov 04, 2019 - 14:17 SAST
Monitoring
A fix has been implemented and success rates are returning to normal. We will continue monitoring performance before closing this issue.
Posted Nov 04, 2019 - 13:38 SAST
Identified
We've identified an issue affecting the timely completion of selected card transactions and are working to resolve it.
Posted Nov 04, 2019 - 12:24 SAST
Investigating
We are seeing a higher than normal failure rate with card transactions. We are investigating to understand what the underlying cause is and to see if changes can be made to improve performance. Instant EFT and other payment methods are unaffected and processing continues as normal.
Posted Nov 04, 2019 - 11:41 SAST
This incident affected: Credit & Cheque cards (Credit and Cheque Card payments).