ABSA Internet Banking Unavailable
Incident Report for PayFast
Resolved
ABSA internet banking is up and running again. Payments through Instant EFT from ABSA are available again as a result.
Posted 6 months ago. Dec 13, 2018 - 15:35 SAST
Monitoring
ABSA Internet Banking is currently down. As a result of this downtime, any payments through Instant EFT from ABSA accounts are not currently possible. Once ABSA have resolved the issue, payments from ABSA will once again be possible through Instant EFT.
Posted 6 months ago. Dec 13, 2018 - 13:04 SAST
This incident affected: Payments :: Instant EFT.