Customer Services Backlog
Incident Report for Payfast
Resolved
We're happy to report that the customer service backlog is now less than 10% of what it was a number of week's ago and turnaround times for all parties are returning to "normal". A reminder that phone support is back again (and has been for a while) for buyers and merchants. Thank you for your patience during this time and our apologies for the drop in customer service levels. We are still seeing massive year on year growth and a surge in demand, but the combination of improvements in operational efficiencies and and increase in staff complement means we are able to effectively deal with such and are well placed for a future of strong continued growth in digital payments and ecommerce.
Posted Jul 22, 2020 - 09:49 SAST
Update
We are happy to report that steady progress has been made through our ticket backlog and turnaround times are reducing daily. As a result, phone support is once again available all customers. There is still a a large backlog, but it is 30% of what it was a number of weeks ago and we hope to have it fully cleared shortly.
Posted Jul 09, 2020 - 15:43 SAST
Monitoring
As a result of overwhelming demand for new accounts combined with greatly increased online payment processing, our customer services team is unable to meet the turnaround times customers would normally expect. We WILL get to your query, but it will take (much) longer than normal and there is little we can do to quickly change that. We are doing everything we can to meet this unforeseeable increase in demand and thank you for your patience and understanding at this time.
Posted May 15, 2020 - 17:57 SAST
This incident affected: General (HelpDesk).