Degraded performance
Incident Report for Payfast
Resolved
Payments continue to flow smoothly and all metrics are stable. This issue is considered resolved, but we continue to monitor closely. We apologise for any inconvenience experienced.
Posted Nov 27, 2020 - 11:43 SAST
Update
We believe we have isolated the source of the issue, made changes and are seeing a return to regular performance. We continue to monitor the issue, but payments should be flowing smoothly again.
Posted Nov 27, 2020 - 11:16 SAST
Update
We continue to see degraded performance and continue to work on the issue. Payments are going through, but certain transactions might time out or return error codes. We apologise for the issues and are working as quickly as possible to resolve.
Posted Nov 27, 2020 - 10:35 SAST
Update
We are continuing to monitor for any further issues.
Posted Nov 27, 2020 - 09:50 SAST
Monitoring
We are experiencing some degraded performance as a result of peak Black Friday volumes. Our technical operations team is attending to the issues.
Posted Nov 27, 2020 - 09:49 SAST
This incident affected: Credit & Cheque cards (Credit and Cheque Card payments), Instant EFT (Capitec, FNB, Standard Bank, Absa, Nedbank, Investec), and Other payment methods (Masterpass, Debit Cards, Mobicred, SCode).