Capitec Internet Banking down
Incident Report for PayFast
Resolved
Capitec internet banking appears to be accessible again.
Posted Nov 01, 2019 - 20:24 SAST
Monitoring
Capitec Internet banking is down (https://downdetector.co.za/status/capitec/). This will affect any clients wishing to pay via Instant EFT from Capitec Bank. We will monitor and advise once regular operation resumes.
Posted Nov 01, 2019 - 18:25 SAST
This incident affected: Payments :: Instant EFT (Capitec).