Standard Bank Internet Banking down or highly unresponsive
Incident Report for PayFast
Resolved
This incident has been resolved.
Posted Oct 06, 2021 - 17:55 SAST
Update
We are continuing to monitor for any further issues.
Posted Oct 06, 2021 - 17:45 SAST
Monitoring
Standard Bank Internet banking is down or highly unresponsive (https://downdetector.co.za/status/standard-bank/). This will affect any clients wishing to pay via Instant EFT from Standard Bank. All other payment methods are unaffected. We will monitor and advise once regular operation resumes.
Posted Oct 06, 2021 - 16:02 SAST
This incident affected: Payments :: Instant EFT (Standard Bank).