Impaired card success rate
Incident Report for Payfast
Resolved
The success rate for payments by card has returned to normal. Our apologies for the issues in this regard.
Posted Feb 15, 2021 - 18:22 SAST
Monitoring
The issue has been identified and a fix deployed. Success rate is returning to normal. We will continue to monitor.
Posted Feb 15, 2021 - 18:04 SAST
Investigating
We are experiencing and impaired success rate for payments by cards. We are investigating the matter with our upstream partners.
Posted Feb 15, 2021 - 17:56 SAST
This incident affected: Credit & Cheque cards (Credit and Cheque Card payments).