Capitec Internet Banking unavailable
Incident Report for PayFast
Resolved
Capitec Internet Banking appears to be back online and transaction success rates are re-establishing.
Posted Oct 25, 2019 - 18:29 SAST
Monitoring
We have detected that Capitec Internet Banking is down again and this is confirmed by a status update on their internet banking site: https://direct.capitecbank.co.za/ibank/

As such, Capitec clients will be unable to pay via Instant EFT until the Capitec Internet banking service is available once again.
Posted Oct 25, 2019 - 17:26 SAST
This incident affected: Payments :: Instant EFT (Capitec).