Mobicred payments are currently not available due to emergency maintenance.
Incident Report for PayFast
Resolved
Mobicred payments are restored and all payments are available.
Posted Oct 04, 2021 - 23:23 SAST
Monitoring
Mobicred payments are currently not available due to emergency maintenance. All other payment methods are unaffected and remain operational.
Posted Oct 04, 2021 - 15:19 SAST
This incident affected: Payments :: Mobicred.