ABSA Internet Banking down
Incident Report for Payfast
Resolved
This incident has been resolved.
Posted Feb 14, 2020 - 20:55 SAST
Monitoring
ABSA banking is down (https://downdetector.co.za/status/absa/). This will affect any clients wishing to pay via Instant EFT from ABSA. We will monitor and advise once regular operation resumes.
Posted Feb 14, 2020 - 17:32 SAST
This incident affected: Instant EFT (Absa).