Failing card transactions due to 3DSecure
Incident Report for Payfast
Resolved
Card transactions have returned to normal.
Posted Jun 25, 2022 - 12:35 SAST
Monitoring
Card transactions are currently failing due to an issue with the upstream 3DSecure network. Our team is monitoring and working with upstream partners to resolve. All other payment methods are available.
Posted Jun 25, 2022 - 11:44 SAST
This incident affected: Credit & Cheque cards (Credit and Cheque Card payments).