Capitec EFT payments offline
Incident Report for PayFast
Resolved
Capitec EFT services have resumed functioning.
Posted Jun 30, 2020 - 12:35 SAST
Monitoring
Capitec website and systems have gone into unscheduled maintenance. Due to this all Capitec EFT payments will be affected. All other payment methods are available and operating normally.
Posted Jun 30, 2020 - 10:00 SAST
This incident affected: Payments :: Instant EFT (Capitec).