Nedbank Credit and Cheque cards are failing
Incident Report for Payfast
Resolved
The error with 3Dsecure and Nedbank cards has been resolved.
Posted Sep 26, 2019 - 17:19 SAST
Identified
We have identified an issue with all Nedbank issued credit and cheque cards where they are currently failing the 3Dsecure process. This issue has been escalated to Bankserv for further investigation and resolution. All other banks and payment methods continue to process successfully at this time.
Posted Sep 26, 2019 - 11:12 SAST
This incident affected: Credit & Cheque cards (Credit and Cheque Card payments).